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Operation Example for Wzpsoft 

Following content will introduce the steps for operating Wzpsoft program by an 

example, user can refer to it when use the program. You can refer to wzphelp.exe for 

other functions and operations. 

Run Wzpsoft program, it will popup a “sign specifications” dialog box as the 

following figure. User can select sign’s colour type from “Colour Type” drop list box 

(it includes nine types), set sign’s width and height. If select “Do not show this next 

time” box, the dialog box will not be showed when run this program next time. User 

can also change the settings through executing “Sign Specification” command under 

“File” menu.  

 

 

 

 

 

 

 

 

 

 

 

11..  CCrreeaattee  **..rrddff  FFiillee  

For instance, here we suppose the user want to send a *.rdf file like below showed 

to the sign. We suppose the file name is Example.rdf. 

 

 

 

 

 

 

 

 

 

We assume that the size for the LED Wzp sign is 64(H)×128(W), the sign is divided 

into four parts (A, B, C and D), we need to set the size for each part for displaying 

normally. 

Fig1.1         

A              B              

C              D              

Fig0 Sign specifications 
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A – 32(H)×64(W), add text file, file name: example1.lmt; 

B – 32(H)×64(W), add image file, file name: example2.png; 

C – 32(H)×64(W), add animation file, file name: example3.gif; 

D – 32(H)×64(W), add sequence file; one sequence file may include some tasks, and a 

task can also include some frames. 

Note: The size for text file, image file, animation file and sequence file must be 

consistent with size for each part. 

 

The *.rdf file may include some text files, image files, animation files and sequence 

files. To create the Example.rdf file, there are following steps mainly: 

Step 1- Create the Text file (Task1); 

Step 2- Create the Image file (Task2); 

Step 3- Create the Animation file (Task3); 

Step 4- Create *.rdf file. 

 

11..11  CCrreeaattee  TTeexxtt  ffiillee  ((**..llmmtt))  

After running Wzpsoft program, click on the new button  or select New from 

the File pull-down menu. Please refer to the following New dialog. 

 

 

 

 

 

 

 

 

 

 

 

Please select Text and click OK button on above figure to create a new text file, it 

will show the text edit box as the following figure. 

Fig1.1.1         
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User needs to set the size for text file, select Page Setup from the Options pull-down 

menu, it will show the following dialog, set some parameters as following figure, then 

click OK button to save the setting. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig1.1.2 

Fig1.1.3 
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Edit text file in the text edit box, you can set the font, size and colour for text content 

by tool bar , and click  

button to save the text file (such as file name is example1.lmt). Please refer to the 

following figure. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click  button on text edit box to exit the text edit box. 

 

 

 

Fig1.1.4 
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11..22  CCrreeaattee  IImmaaggee  ffiillee  ((**..ppnngg,,  **..bbmmpp))  

Please select Image and click OK button on fig1.1.1 to create a new image 

file, it will show the image edit box as the following figure. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

User needs to set the size for image file, select Resize from the Image pull-down 

menu, it will show the following dialog, set some parameters as following figure, then 

click OK button to save the setting. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig1.2.1 

Fig1.2.2 
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Edit image file by drawing panel as following figure.  

 

 

 

 

 

 

 

 

 

 

Click  button to save the image file (such as file name is example2.png). Please 

refer to the following figure. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig1.2.3 

Fig1.2.4 
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Note: You can also open an existing image file by selecting Open from the File 

pull-down menu. 

Click  button on image edit box to exit the image edit box. 

11..33  CCrreeaattee  AAnniimmaattiioonn  ffiillee  ((**..ggiiff))  

Please select Animation and click OK button on fig1.1.1 to create a new 

animation file, it will show the animation edit box as the following figure. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

User needs to set the size for animation file, select Resize from the Image pull-down 

menu, it will show the following dialog, set some parameters as following figure, then 

click OK button to save the setting. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig1.3.1 

Fig1.3.2 
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Edit animation file by drawing panel or select existing animation file by selecting 

Open from the File pull-down menu. 

Click  button to save the animation file (such as file name is example3.gif). Please 

refer to the following figure. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

On right side of the above figure, you can set the delay time for animation file by 

inputting number in Delay box, create another animation file by clicking New button, 

delete one animation file by clicking Delete button, when there are some animation 

files, click Up button to see the last file, click Down button to see the next file, click 

Preview button and it will popup a dialog as following figure to preview the 

animation file 

 

 

 

 

 

 

 

 

 
Fig1.3.4 

Fig1.3.3 
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Click  button on animation edit box to exit the animation edit box. 

11..44  CCrreeaattee  **..rrddff  ffiillee  

The *.rdf file may include some text files, image files and animation files, 

each file may include some frames. Following we will introduce how to create this 

file by an example, it includes one text file, one image file, one animation file and 

one sequence file. 

Please select Script and click OK button on fig1.1.1 to create a new *.rdf file, 

it will show the edit box as the following figure.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Note: Here the screen width and screen height can’t be edited. If need to change the 

settings, you can execute “Sign Specification” command under “File” menu.  

  

Fig1.4.1 
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1.4.1 Add text file (Task1) 

Select Add Message ‘Task’ from the Edit pull-down menu, it will popup Open 

dialog, select one existing text file (such as example1.lmt) form the dialog and add it 

to *.rdf file. It will show the following figure. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click change button to set the size and coordinate for task1, you can refer to the 

following figure. 

Fig1.4.1.1 



OPERATION MANUAL FOR WZPSOFT 

WZPSoft program                                                        V 1.1 

Date: 2011/07/27                                              ©All Rights Reserved. 
11 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

You can also set some parameters for task1, it includes border, schedule, run date and 

time, run days of week, please refer to fig1.4.1.1. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig1.4.1.2 

Fig1.4.1.3 
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The task1 includes three frames, you can set some parameters for each frame, it 

includes move method, speed, direction, pause time, please refer to fig1.4.1.3. 
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1.4.2 Add image file (Task2) 

Select Add Message ‘Task’ from the Edit pull-down menu, it will popup Open 

dialog, select one existing image file (such as example2.png) form the dialog and add 

it to *.rdf file. It will show the following figure. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click change button to set the size and coordinate for task2, you can refer to the 

following figure. 

Fig1.4.2.1 
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You can also set some parameters for task2, it includes border, schedule, run date and 

time, run days of week, please refer to fig1.4.2.1. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig1.4.2.2 

Fig1.4.2.3 
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You can add some frames by selecting Add Image from Edit pull-down menu. 

The task2 includes two frames, you can set some parameters for each frame, it 

includes move method, speed, direction, pause time, please refer to fig1.4.2.3. 
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1.4.3 Add animation file (Task3) 

Select Add Message ‘Task’ from the Edit pull-down menu, it will popup Open 

dialog, select one existing animation file (such as example3.gif) form the dialog and 

add it to *.rdf file. It will show the following figure. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click change button to set the size and coordinate for task3, you can refer to the 

following figure. 

Fig1.4.3.1 
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You can also set some parameters for task3, it includes border, schedule, run date and 

time, run days of week, please refer to fig1.4.3.1. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Fig1.4.3.2 

Fig1.4.3.3 
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The task3 includes eight frames, you can set some parameters for each frame, it 

includes move method, speed, direction, pause time, please refer to fig1.4.3.3. 
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1.4.4 Create sequence file (Sequence1) 

Select Add Group of Messages ‘Sequence’ from the Edit pull-down menu, it 

will show the following figure. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click change button to set the size and coordinate for sequence1, you can refer to the 

following figure. 

Fig1.4.4.1 
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You can also set some parameters for sequence1, it includes schedule, run date and 

time, run days of week, please refer to fig1.4.4.1. 

 

After setting Sequence1, user needs to add text file (Task1) under Sequence1, please 

refer to Section 1.4.1 for adding text file steps. For the Task1 under sequence1, you 

can set the size and coordinate, schedule, priority (Low, Normal, High), run date and 

time, run days of week, please refer to the following figure. 

 

Fig1.4.4.2 
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The task1 includes three frames, you can set some parameters for each frame, it 

includes move method, speed, direction, pause time, please refer to fig1.4.1.3. 

 

 

 

 

Fig1.4.4.3 
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User can also add image file (Task2) under sequence1, please refer to Section 1.4.2 

for adding image file steps. For the Task2 under sequence1, you can set the size and 

coordinate, schedule, priority (Low, Normal, High), run date and time, run days of 

week, please refer to the following figure. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

User can add some frames under task2 by selecting Add Image from Edit pull-down 

menu. The task2 includes two frames, you can set some parameters for each frame, it 

includes move method, speed, direction, pause time, please refer to fig1.4.2.3. 

 

 

 

 

 

Fig1.4.4.4 



OPERATION MANUAL FOR WZPSOFT 

WZPSoft program                                                        V 1.1 

Date: 2011/07/27                                              ©All Rights Reserved. 
23 

 

User can also add animation file (Task3) under sequence1, please refer to Section 

1.4.3 for adding animation file steps. For the Task3 under sequence1, you can set the 

size and coordinate, schedule, priority (Low, Normal, High), run date and time, run 

days of week, please refer to the following figure.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The task3 includes fourteen frames, you can set some parameters for each frame, it 

includes move method, speed, direction, pause time, please refer to fig1.4.3.3. 

 

 

Fig1.4.4.5 
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After adding all files and setting all parameters, the *.rdf file has completed. Click 

WZP Sign icon on edit box, the preview will show the all edited content. Please refer 

to the following figure. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Click  button to save the *.rdf file (such as file name is example.rdf). Please refer 

to the following figure. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Preview box 

Fig1.4.4.6 

Fig1.4.4.7 
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22..  SSeenndd  **..rrddff  FFiillee  ttoo  SSiiggnn  

After editing the file, user needs to send the file content to sign. Here we will 

introduce the steps by taking RS232 communication mode for example. Please refer 

to wzphelp.exe for other communication modes. 

Following will introduce the steps. 

Step1: Select Setup Comm from the Comm pull-down menu, it will show the 

following figure. You need to select protocol of sign, and COM port, input the sign 

address and sign group, select baudrate, then click OK button to save the setting. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Setp2: Select Send from the Comm pull-down menu or click  button, program 

will send all content of the current edited file to sign. 

 

 

Fig2.1 


